BCH deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 18:34 EST
Monitoring
BCH deposits and withdrawals are temporarily unavailable while we perform a required update. All customers’ assets remain secure. We will provide further updates as necessary.
Posted Nov 13, 2019 - 17:51 EST
This incident affected: Bitcoin Cash Deposits & Withdrawals.