Deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 22, 2019 - 12:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jun 22, 2019 - 12:04 EDT
Investigating
We are investigating an issue with deposits and withdrawals. All customers’ assets remain secure. We will provide further updates as necessary.
Posted 3 months ago. Jun 22, 2019 - 11:57 EDT
This incident affected: Bitcoin Deposits & Withdrawals, Ethereum Deposits & Withdrawals, Litecoin Deposits & Withdrawals, Zcash Deposits & Withdrawals, Bitcoin Cash Deposits & Withdrawals, and Gemini Dollar Withdrawals & Redemptions.