ETH deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
ETH deposits and withdrawals are available. Onward and upward!
Posted 6 months ago. Jun 05, 2018 - 22:39 EDT
Monitoring
ETH deposits and withdrawals are temporarily unavailable while we perform a required update. All customers’ assets remain secure. We will provide further updates as necessary.
Posted 6 months ago. Jun 05, 2018 - 20:42 EDT
This incident affected: Ethereum Deposits & Withdrawals.