Service Disruption - Logins through Authy and transactions
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted May 14, 2022 - 13:07 EDT
Investigating
Gemini is investigating reports of potential service disruptions impacting logins through Authy, and transactions. All customer accounts and funds remain completely secure. Further updates to follow.
Posted May 14, 2022 - 12:56 EDT
This incident affected: Gemini ActiveTrader™, Gemini Web UI, Gemini Mobile App, and Authy (Two-Factor Authentication).