Service Disruption - Identification Upload Processing
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 19:00 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 11, 2022 - 17:58 EDT
Update
We are continuing to investigate this issue.
Posted Aug 11, 2022 - 13:15 EDT
Investigating
We are investigating reports of delays in the processing of uploaded identification information via the mobile app.
Posted Aug 11, 2022 - 13:14 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.