Service Disruption (Gemini Credit Card)
Incident Report for Gemini Exchange
Resolved
Our teams have identified and resolved an issue impacting navigation to certain Gemini site pages related to the Gemini Credit Card. Normal navigation functionality has now been restored.
Posted Feb 28, 2023 - 15:05 EST
Investigating
Gemini is investigating reports of potential service disruptions. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Feb 28, 2023 - 14:15 EST
This incident affected: Gemini Credit Card™.