Exchange Login and BTC, ETH, ZEC deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 29, 2018 - 12:33 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Sep 29, 2018 - 12:25 EDT
Identified
Login to exchange.gemini.com, and BTC, ETH, ZEC deposits and withdrawals are temporarily experiencing issues. All customers’ assets remain secure. We will provide further updates as necessary.
Posted 2 months ago. Sep 29, 2018 - 12:00 EDT
This incident affected: Bitcoin Deposits & Withdrawals, Ethereum Deposits & Withdrawals, and Zcash Deposits & Withdrawals.