Bitcoin and Ethereum Upgrade
Incident Report for Gemini Exchange
Resolved
The Gemini Spaceship is back in orbit! Maintenance complete.
Posted 4 months ago. Jan 30, 2018 - 10:04 EST
Investigating
BTC and ETH deposits and withdrawals are temporarily unavailable as we complete a required upgrade. Full functionality should be restored within one hour.
Posted 4 months ago. Jan 30, 2018 - 09:56 EST