Service Disruption - Non-USD Deposits and Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 28, 2021 - 17:05 EST
Identified
Gemini has temporarily disabled Non-USD Deposits and Withdrawals to resolve an underlying issue, and will be applying a fix shortly. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Nov 28, 2021 - 13:48 EST
This incident affected: Fiat Deposits and Withdrawals.