BTC and ETH deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
BTC and ETH deposits and withdrawals have resumed.
Posted Oct 16, 2017 - 15:54 EDT
Monitoring
BTC and ETH deposits and withdrawals are temporarily unavailable as we complete a required upgrade. Full functionality should be restored within one hour.
Posted Oct 16, 2017 - 15:28 EDT