ETH deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted about 2 months ago. Sep 26, 2018 - 18:49 EDT
Monitoring
ETH deposits and withdrawals are temporarily unavailable. All customers’ assets remain secure.
Posted about 2 months ago. Sep 26, 2018 - 18:19 EDT
This incident affected: Ethereum Deposits & Withdrawals.