Transfer History Temporarily Unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jul 13, 2022 - 21:11 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 13, 2022 - 17:41 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 13, 2022 - 17:40 EDT
Investigating
Gemini has identified an issue on the web UI preventing loading of all transfer history and Ethereum transfer history.
Posted Jul 13, 2022 - 17:27 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.