Service Disruption - Web/Mobile UI Account Balance Display Issues
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 20:50 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 11, 2022 - 18:51 EDT
Investigating
Gemini is investigating an issue causing new deposits to not reflect in customer account balances on the web and mobile UIs. This is a display issue only, and all customer accounts and funds remain completely secure. Further updates to follow.
Posted Aug 11, 2022 - 18:07 EDT
This incident affected: Gemini Mobile App and Gemini Web UI.