BTC, ETH, ZEC, BCH, GUSD, LTC deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Apr 04, 2019 - 21:17 EDT
Monitoring
BTC, ETH, ZEC, BCH, GUSD, LTC deposits and withdrawals are temporarily unavailable while we perform a required update. All customers’ assets remain secure. We will provide further updates as necessary.
Posted Apr 04, 2019 - 21:02 EDT
This incident affected: Digital Currencies (Bitcoin Deposits and Withdrawals, Ethereum Deposits and Withdrawals, Litecoin Deposits and Withdrawals, Zcash Deposits and Withdrawals, Bitcoin Cash Deposits and Withdrawals, Gemini Dollar Deposits and Withdrawals).