Service Disruption - Credit Card
Incident Report for Gemini Exchange
Resolved
Upon further investigation, it was determined that this outage was caused by an issue at Mastercard which has since been resolved.
We are working with the Mastercard team to debug further.
Posted Dec 28, 2022 - 14:54 EST
Investigating
Gemini is investigating reports of Credit Card transactions being declined.
Posted Dec 28, 2022 - 14:44 EST
This incident affected: Gemini Credit Card™.