ZEC deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted about 2 months ago. Sep 19, 2018 - 09:49 EDT
Monitoring
ZEC deposits and withdrawals are temporarily unavailable. All customers’ assets remain secure. We will provide further updates as necessary.
Posted about 2 months ago. Sep 19, 2018 - 09:08 EDT
This incident affected: Zcash Deposits & Withdrawals.