Credit Card Application Links
Incident Report for Gemini Exchange
Resolved
Applications are now open to existing Gemini users who are fully verified. If you are a fully verified Gemini user, log in and navigate to the card tab to apply.

For all others who wish to apply for the Gemini Credit Card, please create a Gemini account (https://exchange.gemini.com/register). Once the full verification process is complete, you will be able to navigate to the card tab to apply.

Thanks for your patience!
Posted May 09, 2022 - 16:35 EDT
Update
We appreciate your patience while our teams continue to work on restoring access to Gemini Credit Card applications.
Posted Apr 18, 2022 - 11:03 EDT
Identified
We are working to restore service to our Credit Card application links. Apologies for the inconvenience, please check back with us soon.
Posted Apr 17, 2022 - 14:51 EDT
This incident affected: Gemini Credit Card™.